Back to overview
Resolved

Server Health Test

Jun 21, 2026 at 8:00am UTC  –  Jun 21, 2026 at 8:32am UTC
Affected services
HIS - Frankfurt, Germany
CSV - Amsterdam, Netherlands

Resolved
Jun 21, 2026 at 8:32am UTC

Maintenance complete

Created
Jun 21, 2026 at 8:00am UTC

We're testing the health of our server(s). A slight downtime may occur for services hosted on these servers.